Forum Freedom-IP

Forum d'entraide de la communauté Freedom-IP

Vous n'êtes pas identifié(e).

#1 2014-11-15 14:29:47

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

[LINUX] Configuration Transmission

Bonjour a tous,
suite a cette discussion j'ai effectué quelque recherche sur le net pour voir d’où venais le soucis d'IP transmise par Transmission.
La solution ce trouve ici transmission et vpn

je vais reprendre son TUTO en y ajoutant quelques informations, qui peuvent s'avérer utile.

dans un premier temps il vous faudra l'adresse IP de votre machine

la commande suivante vous donnera l'information (il existe certainement plus simple)

interfaceWWW=`ip -o link show | awk 'BEGIN{} $9=="UP" {gsub(":",""); print $2} END{}'`; ip -o addr | awk -v interfaceWWW=$interfaceWWW '$9==interfaceWWW"\\" {gsub("/.*","");print $4}'

dans mon cas le retour est 192.168.0.1

puis un fichier bash qui contiendra les règle pour le pare feu

#!/bin/bash
# Source NAT and destination NAT rules to make sure the incoming and ougoing packets on 192.168.0.1 are correctly NATed
iptables -A PREROUTING -t nat -i tun0 -p tcp --dport 6891:6899 -j DNAT --to 192.168.0.1
iptables -A PREROUTING -t nat -i tun0 -p udp --dport 6890 -j DNAT --to 192.168.0.1
iptables -A POSTROUTING -t nat -o tun0 -j MASQUERADE
# Allow session continuation traffic
iptables -A INPUT -i tun0 -m state --state RELATED,ESTABLISHED -j ACCEPT
# Allow Bittorrent traffic via tun0
iptables -A INPUT -i tun0 -p tcp --dport 6891:6899 -j ACCEPT                     # rTorrent random range
iptables -A INPUT -i tun0 -p udp --dport 6890 -j ACCEPT                          # DHT
# Disallow BitTorrent traffic via eth0 - Just to be extra safe <img src="http://www.ccaillat.fr/wp-includes/images/smilies/icon_wink.gif" alt=";)" class="wp-smiley">
iptables -A FORWARD -s 192.168.0.1/32 -o eth0 -j DROP

a lancer avec les droits super utilisateur

Modification du fichier de configuration de Transmisson
pour ce faire il nous faut l'adresse du VPN sur notre poste (adresse local)

ip -o addr | awk '$9=="tun0\\" {print $4}'

dans mon cas le retour est 10.8.0.230

et enfin nous modifions le fichier de configuration

sed -i 's/^.*"bind-address-ipv4":.*$/    "bind-address-ipv4": "10.8.0.230",/' ~/.config/transmission/settings.json

rend l'utilisation de Transmission impossible si le VPN n'est pas actif

une petite capture pour montrer le résultat
1416056520.png
Bien entendu BTguard ne fonctionne pas c'est une adresse Freedom IP

Edit : je ne suis pas certain de la pertinence des règles Iptables

Dernière modification par Didier-T (2014-11-15 14:58:33)

Hors ligne

#2 2014-11-15 17:15:50

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Bonjour Didier-T,
Merci beaucoup pour ce tutoriel.
Je suis sûr que ça va aider beaucoup d'entre nous.
J'ai un peu de souci dans la partie Modification du fichier de configuration de Transmisson
La commande

ip -o addr | awk '$9=="tun0\\" {print $4}'

ne fait rien. Donc j'ai obtenu l'adresse du VPN avec la commande

ifconfig

comme vous avez dit qu'on peut le faire autrement.

Maintenant le souci est que le fichier torrent de BTGuard ne peut plus connecter et donne l'erreur Could not connect to tracker
J'ai essayé avec les vrais fichiers torrent. Quelques-uns des trackers marchent mais la plupart ne marchent pas et donnent l'erreur Could not connect to tracker ou Connection failed
Je ne reçois pas l'erreur que vous montrez dans l'image.
Savez-vous pourquoi? Pensez-vous que maintenant je suis protégé?

Dernière modification par member (2014-11-15 17:17:05)

Hors ligne

#3 2014-11-15 18:25:30

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

Re : [LINUX] Configuration Transmission

Re-bonjour,
peut tu me donner le retour de

ip -o addr

ainsi que celui de

ifconfig

et éviter de me vouvoyer  big_smile

Merci

Hors ligne

#4 2014-11-15 19:34:05

chico
l'Axe du bien
Inscription : 2014-05-03
Messages : 695

Re : [LINUX] Configuration Transmission

Bonjour,

Tu peux essayer d'ajouter "redirect-gateway def1 bypass dhcp" et "dhcp-option DNS 10.8.0.1" sans les guillemets à un des fichiers de conf de Freedom-IP

Ou sinon essaye de router ton interface eth0 ou wlan0 vers l'interface tun0 avec une commande du genre "iptables -t nat -A POSTROUTING -s eth0 -o tun0 -j MASQUERADE" à la place de eth0 tu peux aussi essayer avec ton IP locale.

N'oublie pas de nous dire ou tu en es, ça aidera surement quelqu'un d'autre.


U Play...U Pay

Hors ligne

#5 2014-11-15 20:39:28

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Voici les retours lorsque je suis connecté au VPN :

de ip -o addr :

1: lo    inet 127.0.0.1/8 scope host lo\       valid_lft forever preferred_lft forever
1: lo    inet6 ::1/128 scope host \       valid_lft forever preferred_lft forever
3: wlan0    inet 192.168.0.101/24 brd 192.168.0.255 scope global wlan0\       valid_lft forever preferred_lft forever
3: wlan0    inet6 fe80::ba03:5ff:fe63:10c3/64 scope link \       valid_lft forever preferred_lft forever
18: tun0    inet 10.8.31.218 peer 10.8.31.217/32 brd 10.8.31.218 scope global tun0\       valid_lft forever preferred_lft forever

et de ifconfig

eth0      Link encap:Ethernet  HWaddr e8:03:9a:9c:5d:71  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:82827 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:19003065 (19.0 MB)  TX bytes:19003065 (19.0 MB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.8.31.218  P-t-P:10.8.31.217  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:791572 errors:0 dropped:0 overruns:0 frame:0
          TX packets:700243 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:769344780 (769.3 MB)  TX bytes:165958151 (165.9 MB)

wlan0     Link encap:Ethernet  HWaddr b8:03:05:63:10:c3  
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::ba03:5ff:fe63:10c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:33727519 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21551547 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:911230828 (911.2 MB)  TX bytes:1060686260 (1.0 GB)

Just pour préciser : J'ai mis l'adresse du routeur : 10.8.31.218 et pas du P-t-P dans la partie Modification du fichier de configuration de Transmisson

Dernière modification par member (2014-11-15 20:53:02)

Hors ligne

#6 2014-11-15 21:09:08

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

Re : [LINUX] Configuration Transmission

bon, tu es donc en connexion Wifi a l'adresse 192.168.0.101, et ton adresse pour le VPN est 10.8.31.218.
Comme ta connexion est en Wi-Fi les règles iptables bloque tout, car elles sont prévues pour de l’Ethernet.

tu as bien fait pour le fichier de configuration de Transmission smile

pour le script parefeu

#!/bin/bash
# Source NAT and destination NAT rules to make sure the incoming and ougoing packets on 192.168.0.101 are correctly NATed
iptables -A PREROUTING -t nat -i tun0 -p tcp --dport 6891:6899 -j DNAT --to 192.168.0.101
iptables -A PREROUTING -t nat -i tun0 -p udp --dport 6890 -j DNAT --to 192.168.0.101
iptables -A POSTROUTING -t nat -o tun0 -j MASQUERADE
# Allow session continuation traffic
iptables -A INPUT -i tun0 -m state --state RELATED,ESTABLISHED -j ACCEPT
# Allow Bittorrent traffic via tun0
iptables -A INPUT -i tun0 -p tcp --dport 6891:6899 -j ACCEPT                     # rTorrent random range
iptables -A INPUT -i tun0 -p udp --dport 6890 -j ACCEPT                          # DHT
# Disallow BitTorrent traffic via eth0 - Just to be extra safe <img src="http://www.ccaillat.fr/wp-includes/images/smilies/icon_wink.gif" alt=";)" class="wp-smiley">
iptables -A FORWARD -s 192.168.0.101/32 -o wlan0 -j DROP

une petite question, tu es sous quelle version d'Ubuntu et quel environnement ?

Hors ligne

#7 2014-11-15 21:53:56

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Je suis sous Ubuntu 14.04 Gnome et Transmission 2.82    smile

Dernière modification par member (2014-11-15 21:58:54)

Hors ligne

#8 2014-11-16 00:11:16

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Bonjour,
J'ai ajouté les lignes

redirect-gateway def1 bypass dhcp

et

dhcp-option DNS 10.8.0.1

dans l'un des fichiers de configuration. Cependant dans ce cas tous les torrents ne marchent pas.
J'ai ensuite essayé de remplacer la deuxième ligne avec

dhcp-option DNS 10.8.31.218

mais c'est pareil.

Hors ligne

#9 2014-11-16 01:23:47

chico
l'Axe du bien
Inscription : 2014-05-03
Messages : 695

Re : [LINUX] Configuration Transmission

Didier-T a écrit :

pour le script parefeu

#!/bin/bash
# Source NAT and destination NAT rules to make sure the incoming and ougoing packets on 192.168.0.101 are correctly NATed
iptables -A PREROUTING -t nat -i tun0 -p tcp --dport 6891:6899 -j DNAT --to 192.168.0.101
iptables -A PREROUTING -t nat -i tun0 -p udp --dport 6890 -j DNAT --to 192.168.0.101
iptables -A POSTROUTING -t nat -o tun0 -j MASQUERADE
# Allow session continuation traffic
iptables -A INPUT -i tun0 -m state --state RELATED,ESTABLISHED -j ACCEPT
# Allow Bittorrent traffic via tun0
iptables -A INPUT -i tun0 -p tcp --dport 6891:6899 -j ACCEPT                     # rTorrent random range
iptables -A INPUT -i tun0 -p udp --dport 6890 -j ACCEPT                          # DHT
# Disallow BitTorrent traffic via eth0 - Just to be extra safe <img src="http://www.ccaillat.fr/wp-includes/images/smilies/icon_wink.gif" alt=";)" class="wp-smiley">
iptables -A FORWARD -s 192.168.0.101/32 -o wlan0 -j DROP

Il me semble que la dernière règle iptables de ce script interdit tout trafic internet non tunnelisé à travers le VPN, si ce script tourne il ne devrait plus avoir accès à  Internet et donc impossible de joindre les serveurs Freedom-IP sauf si bien-sur il ajoute des règles iptables autorisant l'accès à certains noms de domaines ou adresses IP de FIP

Rectification: c'est la chaîne FORWARD donc ça ne bloque pas l'accès à internet, cette règle empêche juste de passer de tun0 à wlan0, je ne l'ai remarqué qu'en lisant la sortie de iptables -L qu'a poster member.

Dernière modification par chico (2014-11-16 12:55:34)


U Play...U Pay

Hors ligne

#10 2014-11-16 02:17:24

chico
l'Axe du bien
Inscription : 2014-05-03
Messages : 695

Re : [LINUX] Configuration Transmission

Ton problème m'a tellement intrigué que je viens de fraîchement installer un ubuntu 14.04 avec transmission en version 2.82 et connecté en WI-FI, chez moi transmission se connecte bien avec l'adresse IP de FIP, ce qui m'amène à penser que le problème a de fortes chances d'être du à ton proxy, peut-être tu devrais essayer ton PC sur un autre réseau pour voir, si le problème persiste chez un autre FAI c'est que le problème vient forcément de la configuration de ton système.


U Play...U Pay

Hors ligne

#11 2014-11-16 09:13:40

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Bonjour Didier-T et chico,
Je vous remercie pour investir autant derrière ce problème. C'est vraiment très gentil de vos parts de consacrer votre temps.
Je vais essayer de me connecter chez un autre FAI et puis je vous donne les retours.
Mon FAI bloque tout activité torrent. C'est la raison pour la quelle j'utilise un vpn.
Merci encore  smile

Hors ligne

#12 2014-11-16 09:50:34

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

J'ai utilisé la commande suivante :

sudo iptables -L  -v

J'ai obtenu ça comme résultat :

Chain INPUT (policy ACCEPT 652K packets, 663M bytes)
 pkts bytes target     prot opt in     out     source               destination         
 490K  612M ACCEPT     all  --  tun0   any     anywhere             anywhere             state RELATED,ESTABLISHED
    0     0 ACCEPT     tcp  --  tun0   any     anywhere             anywhere             tcp dpts:6891:6899
    0     0 ACCEPT     udp  --  tun0   any     anywhere             anywhere             udp dpt:6890

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 DROP       all  --  any    wlan0   192.168.0.101        anywhere            

Chain OUTPUT (policy ACCEPT 716K packets, 126M bytes)
 pkts bytes target     prot opt in     out     source               destination 

Y a-t-il des problèmes?

Dernière modification par member (2014-11-16 09:58:02)

Hors ligne

#13 2014-11-16 10:21:02

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Je pense que je vais remplacer Transmission avec Deluge. C'était mon client préféré sad
J'ai testé avec Deluge et voilà le vrai IP n'est pas détecté.

Je voudrais voir si Deluge marche sans modification de iptables.
Sauriez vous comment revenir dans l'état précédent c'est à dire défaire les commandes exécuté dans le script ?

Dernière modification par member (2014-11-16 10:48:01)

Hors ligne

#14 2014-11-16 12:46:15

chico
l'Axe du bien
Inscription : 2014-05-03
Messages : 695

Re : [LINUX] Configuration Transmission

Salut member,

Si tu veux réinitialiser toutes les règles iptables :

iptables -F
iptables -X

Si tu veux uniquement supprimer les règles du script tu le recopies en remplaçant

iptables -A

par

iptables -D

c'est quand même bizarre, à mon avis tu devrais aussi réinitialiser la conf de transmission, le problème doit venir de la.


U Play...U Pay

Hors ligne

#15 2014-11-16 14:16:29

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

@Didier-T
@chico

Merci pour la réponse. Deluge marche même avec les iptables réinstallés.

Si jamais je réussi à faire marcher Transmission je vous dirai ici.

Je tiens à vous remercier pour tout aide que vous m'avez apporté. C'était très sympa de vos parts.  smile

Dernière modification par member (2014-11-16 14:17:45)

Hors ligne

#16 2014-11-16 20:13:49

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

Re : [LINUX] Configuration Transmission

pas de soucis, c'est fait pour ça une communauté  cool
c'est juste dommage que le problème d'origine n'est pas été réglé

Hors ligne

#17 2015-05-17 10:04:44

member
Membre
Inscription : 2014-11-13
Messages : 24

Re : [LINUX] Configuration Transmission

Bonjour,
Notre problème ancien : Cela venait de mon coté et c'est tout bête.
Je n'avais pas modifié le champ "Serveur mandataire" dans les paramètres de "Réseau". Une fois que j'ai mis le champ "Méthode" à "Aucun" rien n'était détecté dans Transmission.
Désolé de ne pas pensé à cela.
Deluge ne détectait rien. Peut-être Transmission étant le logiciel fourni par défaut dans Ubuntu a l'accès à ces informations.

Une fois encore, merci @Didier-T et @chico
Cordialement,
member

Hors ligne

#18 2015-05-17 14:02:09

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

Re : [LINUX] Configuration Transmission

Bonjour member,
c'est cool de nous avoir tenu au courant.

Merci a toi,
Didier.

Hors ligne

#19 2015-12-04 01:10:15

ixblanco
Membre
Inscription : 2015-12-03
Messages : 5

Re : [LINUX] Configuration Transmission

bonsoir,

voila j'ai ceci dès le second point :

sudo #!/bin/bash
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
            [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-u user] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
            prompt] [-u user] file ...

pouvez vous m'aidez svp ?


linux mint 17.2 cinnamon

Hors ligne

#20 2015-12-04 07:29:18

David
Bof !!!
Inscription : 2012-01-30
Messages : 6 117

Re : [LINUX] Configuration Transmission

Bonjour ...

Pour le second point, il vous faut créer un fichier ... ceci est le contenu ... utilisez un éditeur de texte simple (pas libre ou open office) du style gedit.

Cordialement, David.


C.G.U.                Règles

Hors ligne

#21 2015-12-04 10:22:11

ixblanco
Membre
Inscription : 2015-12-03
Messages : 5

Re : [LINUX] Configuration Transmission

merci David, et je le met ou le fichier intitulé bash ?

précision je ne suis pas sous VPN mais PPTP ;-)

Dernière modification par ixblanco (2015-12-04 12:33:55)


linux mint 17.2 cinnamon

Hors ligne

Pied de page des forums