Forum Freedom-IP

Forum d'entraide de la communauté Freedom-IP

Vous n'êtes pas identifié(e).

#1 2015-09-05 14:30:31

Patrick1969
Membre
Inscription : 2015-01-23
Messages : 283

Fuite dns

Bonjour
Je suis passé sous linux depuis peu , environ 48 heures , ayez un peu d'indulgence envers moi smile
Voici ce que j'ai fait :
J'ai donné une ip fixe à ma carte réseau et mis le dns sur la valeur 127.0.0.1 .
J'ai ensuite installé bind en suivant le tutoriel du forum , jusqu'à là pas de problème .
Puis j'ai téléchargé l'archive qui me correspondait et installé le vpn auquel je me connecte sans souci , yes !!! cool
Mon problème est le suivant , lorsque je navigue sur internet sans connection au vpn et que je vais sur dnssec pour faire le
test j'ai le message "you are protected" .
Mais , dès que j'active le vpn et que je refait le test sur dnssec j'ai le message "you are not protected" .
Que faire pour être protégé des fuites dns une fois le vpn activé ? Vers où dois je orienter mes recherches ?
D'avance merci de vos réponses , cordialement Patrick1969

Bonsoir ,
J'ai trouvé le problème et maintenant c'est à 100% opérationnel .
En fait le souci venait du network-manager .
Il m'a fallu sélectionner "adresses automatiques uniquement VPN" et dans serveur dns ajouter 127.0.0.1 , un appui sur enregistrer et le tour était joué .
J'ai lancé le vpn puis suis allé sur dnssec et là , le message me dit " you are protected ".
Voilà problème résolu .
Cordialement , Patrick1969  smile

Dernière modification par Patrick1969 (2015-09-05 20:06:32)


L'accès à ce forum reste un privilège et non un droit , n'oubliez pas que nous sommes une communauté et non pas un dû .

Hors ligne

#2 2015-09-08 11:26:25

Patrick1969
Membre
Inscription : 2015-01-23
Messages : 283

Re : Fuite dns

Bonjour .
Voilà j'ai installé la version voyager de linux .
Configuré une ip fixe , mis le dns à 127.0.0.1 sur ma carte réseau .
J'ai appliqué le même dns au vpn puis , installé bind9 .
Seulement voilà , d'après DIDN DNSSEC j'ai toujours une fuite .
" you are not protected " "permissive mode detected " .
Voici ce que me donne la réponse à la commande : dig -x 127.0.0.1

spies @ spies-M  ~
└─ $ ▶ dig -x 127.0.0.1

; <<>> DiG 9.9.5-3ubuntu0.5-Ubuntu <<>> -x 127.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15073
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;1.0.0.127.in-addr.arpa.		IN	PTR

;; ANSWER SECTION:
1.0.0.127.in-addr.arpa.	604800	IN	PTR	localhost.

;; AUTHORITY SECTION:
127.in-addr.arpa.	604800	IN	NS	localhost.

;; ADDITIONAL SECTION:
localhost.		604800	IN	A	127.0.0.1
localhost.		604800	IN	AAAA	::1

;; Query time: 1 msec
;; SERVER: 127.0.1.1#53(127.0.1.1)
;; WHEN: Tue Sep 08 12:23:51 CEST 2015
;; MSG SIZE  rcvd: 132

spies @ spies-M  ~
└─ $ ▶  

Si vous avez des propositions , je suis preneur smile
Cordialement , Patrick1969


L'accès à ce forum reste un privilège et non un droit , n'oubliez pas que nous sommes une communauté et non pas un dû .

Hors ligne

#3 2015-09-08 18:57:31

xamzab
SysOps
Inscription : 2013-03-21
Messages : 2 138

Re : Fuite dns

Bonjour,

Avec l'AntiDNS Leaks, le système va traiter vos requêtes DNS sur le serveur VPN directement, donc plus besoin de DNS local sur sa machine. Et en plus, c'est compatible toute plateforme puisque c'est une implémentation via une fonctionnalité d'OpenVPN.


If privacy is outlawed, only outlaws will have privacy.

Hors ligne

#4 2015-09-09 16:21:13

Didier-T
Contributeurs Confirmés
Lieu : Argenteuil
Inscription : 2014-02-01
Messages : 323

Re : Fuite dns

Bonjour Patrick1969,
le souci avec les solutions de tests de sécurité proposées par des marchands vendant des solutions sécurisantes, c'est que s'il ne trouve pas le résultat voulu (eux) il te dise que rien ne va.
Pour un vrai test de fuite DNS rend toi cher DNSleaktest et regarde si ton opérateur apparaît sur le résultat de test, si c'est le cas tu as bien une fuite.

Juste pour info, si tu te connectes au VPN via Openvpn en ligne de commande il te faudrat modifier le fichier de configuration .ovpn en y ajoutant les lignes suivantes en fin de fichier:

script-security 2
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

A+,
Didier.

Hors ligne

Pied de page des forums