Forum Freedom-IP VPN

Forum d'entraide de la communauté Freedom-IP VPN

Vous n'êtes pas identifié(e).

#1 2012-01-25 10:26:12

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Pas de secrets VPN valides ? (linux)

Bonjour,

Sous Ubuntu 10.04, j'ai suivi le tuto vidéo, mais à la connexion j'ai ce message d'erreur:
La connexion a echoué car il n'y avait pas de secrets VPN valides.

Qu'est-ce que cela signifie ? Comment résoudre ce problème ?

Hors ligne

#2 2012-01-25 10:29:12

Back2back
Contributeurs Confirmés
Inscription : 2011-11-20
Messages : 4 330
Site Web

Re : Pas de secrets VPN valides ? (linux)

Bonjour,
il est possible que tes ID soit mal rentrés, ou qu'ils ne soient pas valides.
essaye de te connecter au compte sur le site
je regarde en attendant smile

EDIT: Je pense effectivement que tu as fait une erreur dans tes ID et MDP

Hors ligne

#3 2012-01-25 10:37:24

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Salut et merci de ta réponse.

J'ai fait du copier/coller pour mi ID et mon MDP.

Je viens de changer mon MDP via mon compte, mais le problème persiste.

Hors ligne

#4 2012-01-25 10:39:51

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Je viens de suivre cette solution :

http://blog.nicolargo.com/2010/09/confi … buntu.html

(chapitre: "et si cela ne marche pas ?")

Maintenant, j'ai le message d'erreur suivant:

La connexion VPN "NL2_freedomip" a echoué car le service VPN a été arrêté de manière inattendue.

Hors ligne

#5 2012-01-25 10:46:34

Antonin
Membres de confiance
Inscription : 2011-11-28
Messages : 3 729

Re : Pas de secrets VPN valides ? (linux)

Bonjour,

Quitte à remettre comme c'était avant ton message de 10h39, regarde ça:
https://freedom-ip.com/forum/viewtopic.php?id=51

Si pb secrets vpn non valides :

"Il suffit de modifier le fichier /etc/dbus-1/system.d/nm-openvpn-service.conf en ajoutant:

    <policy user="at_console">

    <allow own="org.freedesktop.NetworkManager.vpnc"/>

    <allow send_destination="org.freedesktop.NetworkManager.vpnc"/>

    </policy>

Ce qui donne donc:

    <busconfig>

    <policy user="root">

    <allow own="org.freedesktop.NetworkManager.openvpn"/>

    <allow send_destination="org.freedesktop.NetworkManager.openvpn"/>

    </policy>

    <policy user="at_console">

    <allow own="org.freedesktop.NetworkManager.vpnc"/>

    <allow send_destination="org.freedesktop.NetworkManager.vpnc"/>

    </policy>

    <policy context="default">

    <deny own="org.freedesktop.NetworkManager.openvpn"/>

    <deny send_destination="org.freedesktop.NetworkManager.openvpn"/>

    </policy>

    </busconfig>

Après cette manipulation et un reboot tout devrait rentrer dans l'ordre."

Hors ligne

#6 2012-01-25 10:47:52

Back2back
Contributeurs Confirmés
Inscription : 2011-11-20
Messages : 4 330
Site Web

Re : Pas de secrets VPN valides ? (linux)

Bonjour, oui c'est normal tu as déplacé des fichiers ou il ne fallait pas
dsl je commence linux donc je vais etre limité dans l'aide.

    sudo aptitude install openvpn resolvconf network-manager-openvpn-gnome

    sudo mkdir /etc/openvpn/keys

la première ligne normalement tu devais avoir installer network-manager-openvpn-gnome par synaptics
la deuxième ligne, sert a créer un dossier mais j'en vois pas l'utilité smile

[== Indéfini ==]
    sudo cp openvpn.conf /etc/openvpn/

    sudo cp ca.crt /etc/openvpn/keys/

et je vois pas l'intéret d'avoir copier cela.

quand t'es tu inscrit?

Hors ligne

#7 2012-01-25 11:10:48

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

@ Antonin:

ok. J'ai enlevé ce que j'avais ajouté dans le fichier nm-openvpn-service.conf.

J'ai désinstallé et réinstallé openvpn.

Maintenant j'ai ce message :

La connexion VPN "NL2_freedomip" a echoué car le délai de connexion est dépassé.


@ Back2back:

Je n'ai pas effectué les commandes dont tu parles. J'ai juste effectué ce qui se trouve dans le chapitre "et si cela ne marche pas ?".

Hors ligne

#8 2012-01-25 12:17:29

ycD
Membre
Inscription : 2012-01-24
Messages : 51

Re : Pas de secrets VPN valides ? (linux)

J'attire l'attention sur le fait que la vidéo est erronée pour une compatibilité linux.

Les certificats doivent se trouver en root ici par exemple :

/etc/openvpn/freedomip/

Auquel cas cela ne fonctionnera pas sous Fedora entre autre...

Hors ligne

#9 2012-01-25 13:26:15

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

J'ai mis le fichier ca.crt dans /etc/openvpn/freedomip/

Mais cela ne change rien.

Faut-il ouvrir un port dans la box ?
Faut-il configurer le pare-feu d'Ubuntu de manière particulière ?

Hors ligne

#10 2012-01-25 13:32:59

ycD
Membre
Inscription : 2012-01-24
Messages : 51

Re : Pas de secrets VPN valides ? (linux)

Tu copies TOUT le répertoire décompressé freedomip dans /etc/openvpn/freedomip/ pas seulement le le crt, le key également et les autres.
(Et tu les copies en root en t'assurant qu'ils sont lisibles par tous)

Ensuite tu importes le .ovpn de ce répertoire, comme indiqué dans la vidéo et tu testes.

Quelle est ta box ?
As tu un firewall ?

Dernière modification par ycD (2012-01-25 13:34:52)

Hors ligne

#11 2012-01-25 13:35:01

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

J'ai une livebox.

J'ai le parefeu intégre à Ubuntu: Gufw

Hors ligne

#12 2012-01-25 13:37:00

ycD
Membre
Inscription : 2012-01-24
Messages : 51

Re : Pas de secrets VPN valides ? (linux)

Tu as testé ?

Si oui et cela ne fonctionne pas, désactive ton parefeu.

Sinon comment est configurée ta livebox (mode routeur, firewall) ?

Dernière modification par ycD (2012-01-25 13:39:22)

Hors ligne

#13 2012-01-25 13:39:44

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Je n'aime pas trop désactiver mon pare-feu....Je veux bien tenter pour voir, mais je ne conçois pas de le laisser désactiver pendant de longues périodes.

Pour ma box, que veux-tu savoir exactement ?

Hors ligne

#14 2012-01-25 13:54:40

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Oups, nos messages se sont croisés.

Je ne sais pas comment répondre à ta question sur ma box.
Quand tu demandes "mode routeur, firewall", que veux-tu connaitre ?

Je n'ai pas de port ouverts sur ma box. C'est peut-être ce que tu veux savoir quand tu demandes "firewall"...

mode routeur ? où puis-je trouver l'info ?

Hors ligne

#15 2012-01-25 14:48:17

Magicalex
Membre
Inscription : 2011-11-21
Messages : 35

Re : Pas de secrets VPN valides ? (linux)

On n'a déjà parlé de ce problème sur le forum.

effectivement il faut mettre les fichiers de configuration dans /etc/openvpn/etc... (en fonction de ce que l'on veut)

Pour les ports normalement ils sont déjà ouvert cela m'étonnerais que ça vienne de ça..

Une mise à jour du tuto s'impose je pense (je vais voir si je peux faire quelque chose)

Hors ligne

#16 2012-01-26 11:04:59

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Salut,

Les ports sont déjà ouverts ? Par qui ? Quand ? Je pensais que les ports de ma box étaient fermés par défaut. S'il y a des ports ouverts par défaut, le logiciel de ma box pourrait au moins m'informer desquels il s'agit...   hmm

Ceci étant dit, même en plaçant les fichiers à la bonne place, le problème reste le même ("délai de connexion est dépassé").
N'y aurait-il pas une saturation des serveurs ?

Hors ligne

#17 2012-02-01 01:15:14

kriss
Membre
Inscription : 2012-02-01
Messages : 15

Re : Pas de secrets VPN valides ? (linux)

Bonsoir, j'ai le même souci.

J'ai tout bien fait, mis les fichiers où il le faut en root, même désactivé le firewall pour voir si cela pouvait venir de ça, rien à faire.

Sous windaube, ça a marché du 1er coup, ici, même après une heure, rien de nada, allez comprendre : "la connexion VPN a échoué car le temps d'attente est dépassé"...

Les mots de passes et identifiants sont ok, et ça marche sous windaube, donc pas possible que ce soit la box.

Au début j'avais modifié le fichier config comme le disait Antonin, et j'ai remis comme avant.

Moi qui comptais passer tout mes PC sous linux, on va attendre big_smile

Quelqu'un a la solution ?

Hors ligne

#18 2012-02-01 10:13:18

David
Bof !!!
Inscription : 2012-01-30
Messages : 6 131

Re : Pas de secrets VPN valides ? (linux)

Bonjour... pour linux (debian et dérivés), rien de plus simple. En administrateur (root):

- Créer un répertoire "/etc/openvpn/freedom-ip".
- Copier les fichier "ca.crt" et "ta.key" dans le répertoire "/etc/openvpn/freedom-ip".
- Créer le fichier "/etc/openvpn/freedom-ip/passwd" (si vous souhaitez une connection automatique) avec:
    en première ligne "votre identifiant : fip_..."
    en seconde  ligne "votre mot de passe freedom-ip"
- Copier un des fichiers ".ovpn" dans le répertoire "/etc/openvpn" sous le nom "freedom-ip.conf"
- Modifier les lignes de votre "/etc/openvpn/freedom-ip.conf"
    "ca ca.crt"             devient "ca /etc/openvpn/freedom-ip/ca.crt"
    "tls-auth ta.key 1" devient "tls-auth /etc/openvpn/freedom-ip/ta.key 1"
    "auth-user-pass"   devient "auth-user-pass /etc/openvpn/freedom-ip/passwd" (pour la connection automatique)

ensuite un petit:
$ /etc/init.d/openvpn restart
vous devriez avoir un vpn d'actif... pour le vérifier
$ ifconfig
...
tun0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 
          inet adr:10.8.0.???  P-t-P:10.8.0.???  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          ...
...
faites les vérifications qui s'imposent pour les routes et autres... en fonction de vos besoins, de votre configuration.

Cordialement, David.

Dernière modification par David (2012-02-01 10:26:01)


C.G.U.                Règles

Hors ligne

#19 2012-02-01 12:42:15

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Merci pour ces précisions !
Mais j'ai suivi à la lettre tes indications, et quand je restart openvpn, j'ai ceci:

* Stopping virtual private network daemon(s)...                               
*   No VPN is running.
* Starting virtual private network daemon(s)... 

Et ensuite, ifconfig ne me retourne que eth0 et lo.

Hors ligne

#20 2012-02-01 14:28:49

David
Bof !!!
Inscription : 2012-01-30
Messages : 6 131

Re : Pas de secrets VPN valides ? (linux)

pseudo23 a écrit :

Merci pour ces précisions !
Mais j'ai suivi à la lettre tes indications, et quand je restart openvpn, j'ai ceci:

* Stopping virtual private network daemon(s)...                               
*   No VPN is running.
* Starting virtual private network daemon(s)... 

Et ensuite, ifconfig ne me retourne que eth0 et lo.

Dans le fichier "/etc/default/openvpn", la variable AUTOSTART est-elle initialisée avec la valeur "all" !?

Sinon, pour voir s'il y a des erreurs de démarrage, exécuter en tant qu'administrateur (root):
$ openvpn --config /etc/openvpn/freedom-ip.conf --script-security 2

Cordialement, David.

Dernière modification par David (2012-02-01 14:32:50)


C.G.U.                Règles

Hors ligne

#21 2012-02-02 11:15:56

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Merci de ta réponse.

Autostart est bien "all".

Les erreur au démarrage sont :

Thu Feb  2 11:13:28 2012 OpenVPN 2.1.0 x86_64-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 20 2010
Thu Feb  2 11:13:28 2012 WARNING: file '/etc/openvpn/freedom-ip/passwd' is group or others accessible
Thu Feb  2 11:13:28 2012 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Thu Feb  2 11:13:28 2012 WARNING: file '/etc/openvpn/freedom-ip/ta.key' is group or others accessible
Thu Feb  2 11:13:28 2012 Control Channel Authentication: using '/etc/openvpn/freedom-ip/ta.key' as a OpenVPN static key file
Thu Feb  2 11:13:29 2012 Attempting to establish TCP connection with [AF_INET]46.21.145.157:9999 [nonblock]
Thu Feb  2 11:13:39 2012 TCP: connect to [AF_INET]46.21.145.157:9999 failed, will try again in 5 seconds: Connexion terminée par expiration du délai d'attente
Thu Feb  2 11:13:54 2012 TCP: connect to [AF_INET]46.21.145.157:9999 failed, will try again in 5 seconds: Connexion terminée par expiration du délai d'attente
Thu Feb  2 11:14:10 2012 TCP: connect to [AF_INET]46.21.145.157:9999 failed, will try again in 5 seconds: Connexion terminée par expiration du délai d'attente
(etc)

Hors ligne

#22 2012-02-02 11:18:21

Freedom-IP
Administrateur
Inscription : 2011-11-20
Messages : 1 819

Re : Pas de secrets VPN valides ? (linux)

Le fichier sur lequel vous essayé de vous connecté :

Thu Feb  2 11:13:29 2012 Attempting to establish TCP connection with [AF_INET]46.21.145.157:9999[nonblock]

Port 9999 à remplacer par port 443.


N'existe plus vous pouvez le supprimer et le remplacer par les nouveaux fichiers de configuration wink

Hors ligne

#23 2012-02-02 11:28:39

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

ok.
Nouveau message d'erreur:

Thu Feb  2 11:25:42 2012 OpenVPN 2.1.0 x86_64-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 20 2010
Enter Auth Username:fip_xxxxxxxxxx
Enter Auth Password:
Thu Feb  2 11:26:14 2012 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Thu Feb  2 11:26:14 2012 Cannot load CA certificate file ca.crt path (null) (SSL_CTX_load_verify_locations): error:02001002:system library:fopen:No such file or directory: error:2006D080:BIO routines:BIO_new_file:no such file: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib
Thu Feb  2 11:26:14 2012 Exiting

Hors ligne

#24 2012-02-02 17:26:55

David
Bof !!!
Inscription : 2012-01-30
Messages : 6 131

Re : Pas de secrets VPN valides ? (linux)

Bonjour.

Il vous dit simplement que le fichier ca.crt n'a pu être ouvert. Vérifiez qu'il est bien à l'endroit voulu.
Si vous avez modifier le freedom-ip "ca ca.crt" en "ca /etc/openvpn/freedom-ip/ca.crt" et qu'il ne se trouve pas dans le répertoire "/etc/openvpn/freedom-ip", copiez le dans ce répertoire.

Cordialement, David.


C.G.U.                Règles

Hors ligne

#25 2012-02-03 11:37:14

pseudo23
Membre
Inscription : 2012-01-25
Messages : 69

Re : Pas de secrets VPN valides ? (linux)

Bonjour et merci pour la réponse,

J'ai maintenant une nouvelle erreur:

Fri Feb  3 11:34:41 2012 OpenVPN 2.1.0 x86_64-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [MH] [PF_INET6] [eurephia] built on Jul 20 2010
Fri Feb  3 11:34:41 2012 WARNING: file '/etc/openvpn/freedom-ip/passwd' is group or others accessible
Fri Feb  3 11:34:41 2012 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Fri Feb  3 11:34:41 2012 WARNING: file '/etc/openvpn/freedom-ip/ta.key' is group or others accessible
Fri Feb  3 11:34:41 2012 Control Channel Authentication: using '/etc/openvpn/freedom-ip/ta.key' as a OpenVPN static key file
Fri Feb  3 11:34:42 2012 Attempting to establish TCP connection with [AF_INET]173.245.61.61:443 [nonblock]
Fri Feb  3 11:34:43 2012 TCP: connect to [AF_INET]173.245.61.61:443 failed, will try again in 5 seconds: Connexion refusée

(y arriverai-je un jour ?)

Hors ligne

Pied de page des forums